Bents Blog

 

Ein IT Blog mit Themen aus dem Windows Server Umfeld.

WMI Fehler: Fehlgeschlagene Abfrage mit Event ID 10, 0x80041003

Der hier beschriebene Fehler trat auf zwei virtuellen Maschinen auf, die ich in einem aktuellen Kundenprojekt installiert und konfiguriert habe. Inzwischen tauchte der Fehler auf mehreren Servern- allerdings bei mir immer in virtuellen Umgebungen – auf.

Problem

Von acht jeweils unter VMware vSphere (Version 4.1 U1) virtualisierten Maschinen trat die folgende Fehlermeldung auf lediglich zwei Terminalservern (Mitglieder einer Farm, Network Load Balancing installiert und aktiviert) auf:

Ereignisfilter mit Abfrage „SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA „Win32_Processor“ AND TargetInstance.LoadPercentage > 99″ konnte im Namespace „//./root/CIMV2“ nicht reaktiviert werden aufgrund des Fehlers 0x80041003. Ereignisse können nicht durch diesen Filter geschickt werden, bis dieses Problem gelöst ist.

Als Betriebssystem kommt auf allen Maschinen Windows Server 2008 R2 Datacenter Edition mit ServicePack 1 zum Einsatz. Der Fehler taucht im Ereignisprotokoll Anwendung bei jedem Neustart der Server auf.

Lösung

Der Dienst Windows-Verwaltungsinstrumentation (winmgmt) muss zunächst beendet werden – entweder in der Dienste Management Konsole oder auf der Kommandozeile mit dem folgenden Befehl:

net stop winmgmt

In dessen Abhängigkeit stehen (bei installierten VMware Tools) die beiden Dienste – beide werden automatisch mit beendet:

  • IP-Hilfsdienst
  • VMware-Upgrade-Hilfsprogramm

Nach dem Beenden der genannten Dienste lässt sich im Anschluss der komplette Inhalt des Verzeichnisses

%SystemRoot%\System32\wbem\Repository

löschen.

Zur Sicherheit sollte man die betreffenden Dateien INDEX.BTR, OBJECTS.DATA und MAPPINGx.MAP vor dem Löschen sichern – mittlerweile verzichte ich aus der Erfahrung heraus darauf. Nach einem Neustart des Systems werden diese aber automatisch neu erzeugt.

Der oben beschriebene Fehler taucht anschließend nicht mehr auf.

Fazit

Im Internet kursieren unterschiedliche Hilfestellungen und Lösungsvorschläge zu dem oben geschildertem Problem. In meinem Fall half letztendlich nur die hier beschriebene Lösung. Wer einen einfacheren und schnelleren Weg kennt, den bitte ich um ein kurzes Feedback. Wie bei allen meinen Beiträgen gilt: Bei Tipps, Vorschlägen sowie Fragen oder Kritiken hinterlasst bitte einen Kommentar.

Einen Blog am Leben zu erhalten kostet Zeit und Geld. Da ich auf meiner Seite weder Werbung einbinde, noch andersweitige Zuwendungen erhalte, freue ich mich über jede kleine Spende. Einfach und unkompliziert geht das über PayPalMe. Du unterstützt damit diesen Blog. Vielen Dank.

15 Kommentare für “WMI Fehler: Fehlgeschlagene Abfrage mit Event ID 10, 0x80041003”

  • Johannes Sebald

    Hallo Bent,

    vilen Dank für diesen Lösungsansatz. Er funktioniert einwandfrei. Bei mir handelte es sich um zwei Hyper-V Gastmaschinen mit einmal Ws2008R2 SP1 Standard und einmal Windows 7 Pro SP1. Der Hyper-V Host wird ebenfalls mit WS2008R2 SP1 Std. betrieben.
    Hat mir sehr weitergeholfen, Danke!

  • SAM

    Vielen Dank für die Lösung. Hat wunderbar geklappt ;-)

    Hat auch mir wirklich geholfen!

    Liebe Grüße
    S.A.M.

  • Cobucom

    Hat auf einem nagelneuen Toshiba-Notebook mit W7prof 64bit – SP1 soeben ohne Probleme funktioniert.

    Vielen Dank!
    CC

  • mmueller

    Hallo,

    ich kann leider die Dateien im Repository-Ordner nicht löschen, da dies bei Win7 Sp1 nicht möglich ist!
    Können Sie mir weiterhelfen!

    Vielen Dank im Voraus!

  • Bent Schrader

    Hallo,

    die Dateien lassen sich auch unter Windows 7 SP1 löschen. Der Dienst Windows-Verwaltungsinstrumentation muss dafür aber beendet sein. Bitte kontrollieren und dann löschen.

    Gruß,
    Bent

  • Flo

    Hallo,

    wollte meinen Fehler ebenfalls beheben… nach der Bestätigung des net stop winmgmt Befehls erhalte ich die Meldung „Systemfehler 5 aufgetreten – Zugriff verweigert“.
    Ein admin-Problem?

    Vielen Dank im Voraus
    Florian

  • Bent Schrader

    Hallo Flo,

    Du bist Dir sicher, dass der Dienst winmgmt beendet wurde? Prüfen kannst Du das via

    net query winmgmt

    Unter Windows 7 hatte ich bereits das Problem, dass noch andere Dienste von der Windows-Verwaltungsinstrumentation abhängig waren, die nicht beendet wurden.

    Gruß,
    Bent

  • Sky

    Super Tipp … der funktioniert übrigens auch mit Windows 2012 Server.

  • t-media

    hmm ich habe es probiert funktioniert aber nur bis zum nächesten neustart,

    denn dann kommt dieses wmi problematik wieder und wieder!

    bin am ENDE

    grüße

  • Zebratta

    Super. Fehler ist weg unter Win7 Pro64 SP1

  • zitze

    @ Flo

    und den anderen jungs…. ihr müsst die Eingabeaufforderung auch in admin -modus starten……
    rechte Maustaste und da steht als Admin ausführen.Danach den Befehl rein….warten…danach die Dateien löschen…Neustart…habe fertig :-). geht in Win7 +Sp1 …..thx from Tip

  • Uschi

    @Flo
    Bei mir wurde der Dienst immer wieder neu gestartet, nadem ich ihn beendet hatte. Geholfen hat das ich den Dienst winmgmt auf „deaktiviert“ stelle und anschließen beende. Danach kann man die Dateien löschen:)

    ansonsten Super vielen Dank für den TIP

  • DWE

    Hat mir geholfen, vielen Dank!

    Konfiguration war identisch (Windows Server 2008 R2 Datacenter Edition mit ServicePack 1)

  • HPJ

    Ich betreibe einen W2K8R2 Server auf MAC OSX Version 10.7.5 mit Parallels und liebe ein Störungsfreies Event Log. Deine Ausführung hat mir – im gegensatz zu einigen andern – geholfen den Fehler in den Griff zu bekommen!

    Habe herzlichen Dank für Deine präzisen Ausführungen

    Viele Grüße aus Schwaben
    HPJ

  • Micha

    Vielen Dank, hat geklappt mit W7-64 SP1, allerdings muss 2x neu gestartet werden, zuerst hatte ich da jede Menge WMI Warnungen das sich Anbieter registriert haben, nach dem 2. Start kam aber keine Fehlermeldung mehr. Wird das durch die neu erstellten Dateien verursacht die ich vorher gelöscht habe?

    Danke nochmals, Micha.

Einen Kommentar hinterlassen:

Antispam Bee hat Bent's Blog vor 410.433 Spam-Kommentaren bewahrt.