Bents Blog

 

Ein IT Blog mit Themen aus dem Windows Server Umfeld.

Hyper-V-Manager in Windows 10 meldet Fehler bei Verbindung mit Hyper-V-Server 2012 R2

Seit kurzer Zeit habe auch ich meine Rechner auf Windows 10 aktualisiert. Ich bin mit dem neuen Betriebssystem absolut zufrieden, es funktionieren – beruflich wie auch auf meinen privaten PCs –  nahezu alle Anwendungen problemlos.

Problem

Auf meinem Firmen-Notebook versuchte ich nach dem Update eine Test-Umgebung auf einem Hyper-V-Server 2012 R2 mit dem Hyper-V-Manager zu erreichen. Bei dem Verbindungsversuch mit dem Server erhielt ich jedoch folgende Fehlermeldung:

The WS-Management service cannot process the request.  The class Msvm_RegisteredProfile does not exist in the root/interop Namespace.

Hyper-V-Manager Fehlermeldung

Ursache

Eines vorweg: Es ist kein Client-Problem. Vermutlich hängt das Problem mit einem fehlerhaften Update auf Servern von Hewlett-Packard zusammen. Der betroffene Hyper-V-Server 2012 R2 läuft zumindest auf einem DL360 G7.

Lösung

Ein freundlicher Arbeitskollege fand schließlich den entscheidenden Hinweis. Auf dem betroffenen System meldete ich mich via RDP an und rief den folgenden Befehl in der Kommandozeile auf:

mofcomp %SYSTEMROOT%\System32\WindowsVirtualization.V2.mof

Dadurch wird die zuständige Managed Object Format (MOF)-Datei neu kompiliert. Diese beinhaltet die Klassen und Instanzen, die dem WMI Repository hinzugefügt werden. Im Anschluss konnte sich der Hyper-V-Manager ohne Probleme mit dem Server verbinden, der Fehler ist damit behoben.

Fazit

Leider ist mir nicht bekannt, welches Update den Fehler auf dem HP Server verursacht hat. Für den Fall, dass ein Leser dieses Artikels die genaue Antwort kennt, würde ich mich über eine kurze Information freuen. Wie bei allen meinen Beiträgen gilt: Bei Tipps, Vorschlägen sowie Fragen oder Kritiken hinterlasst bitte einen Kommentar.

Einen Blog am Leben zu erhalten kostet Zeit und Geld. Da ich auf meiner Seite weder Werbung einbinde, noch andersweitige Zuwendungen erhalte, freue ich mich über jede kleine Spende. Einfach und unkompliziert geht das über PayPalMe. Du unterstützt damit diesen Blog. Vielen Dank.

15 Kommentare für “Hyper-V-Manager in Windows 10 meldet Fehler bei Verbindung mit Hyper-V-Server 2012 R2”

  • Johannes Sebald

    Hallo Bent, vielen Dank für deinen Artikel. Die Lösung funktioniert problemlos mit Windows Server 2012 R2 und Hyper-V Server 2012 r2.

  • Johannes Sebald

    Hallo Bent, leider ergibt sich dadurch ein neues Problem: Die Boot-Reihenfolge (Firmware) von Gen2 VMs wird nicht mehr korrekt angezeigt. Es wird kein Harddrive und kein DVD mehr angezeigt, sobald der Befehl ausgeführt wurde. Tritt das Problem auch bei dir auf?

  • Bent Schrader

    Hallo Johannes,

    Du hast Recht, im Menü Firmware existiert nur der Eintrag [Datei, bootmgfw.efi].
    Hast Du hier schon eine Lösung gefunden?

    Viele Grüße,
    Bent

  • Uwe Sarpe

    Hatte das gleiche Problem bei mehreren Netzen, funktioniert zu 100% danke, das soll ein Mensch drauf kommen.

  • Johannes Sebald

    Hallo Bent,

    wie bereits im TechNet Thread beschrieben, löst man das Problem, indem man die Hyper-V Rolle auf den betroffenen Servern entfernt und wieder hinzufügt.

    PowerShell:
    Remove-WindowsFeature Hyper-V
    (Zweimal Windows-Neustart)

    Install-WindowsFeature Hyper-V
    (Zweimal Windows-Neustart)

    Ein Zugriff mit dem Windows 10 Hyper-V-Manager ist danach weiterhin möglich.

    Die Frage lautet: Genügt ein Entfernen und wieder hinzufügen der Hyper-V-Rolle, um einen Zugriff unter Windows 10 zu ermöglichen, ohne die MOF-Datei zu kompilieren?

    Gruß
    Johannes

  • Harald

    Hallo,
    gehen durch das Entfernen und wieder hinzufügen der Hyper-V Rolle die Einstellungen / Switche verloren oder funktioneirt danach gleich wieder alles?

    Gruß
    Harald

  • Johannes Sebald

    Hallo Harald,

    ich empfehle grundsätzlich eine regelmäßige Dokumentation aller Hyper-V-Einstellungen inklusive der NIC-Einstellungen und die Einstellungen der virtuellen Hyper-V-Switche.

    Die Einstellungen der virtuellen Hyper-V-Switche sind nach einem Entfernen und Hinzufügen der Hyper-V-Rolle nicht mehr vorhanden und müssen (manuell) wederhergestellt werden (GUI oder PowerShell).

    Danach müssen bei allen virtuellen Maschinen in der Netzwerkkarte der virtuelle Switch neu ausgewählt und bestätigt werden.

    Gruß
    Johannes

  • Norbert Dregger

    Ich breche zusammen – gleiches Problem – gleiche Lösung! Vorallem: Das Problem tritt erst bei dem Versuch aus von Windows 10 Maschinen aus den Hyper-V zu verwalten, bei Windows 8.1 Maschinen gibt es auch ohne den Aufruf von mofcomp keine Probleme! Daher habe ich erst einmal ein Problem zwischen Windows 10 und Server 2012 R2 vermutet!

    Danke für den Tip!

    Gruß
    Norbert

  • Norbert Dregger

    Hatte das gleiche Problem nach Neuinstallation des aktuellen HP SPP gerade wieder – Befehl wieder laufen lassen und es funktioniert auch wieder remote!

    VIELEN DANK

    Norbert

  • Manu

    Vielen Dank, hatte das gleiche Problem!

  • teh_pwnerer

    Vielen Vielen Dank!
    mofcomp %SYSTEMROOT%System32WindowsVirtualization.V2.mof
    „neu kompilieren klingt für mich immer nach nem längeren Vorgang, in diesem Fall brauchte es nur sekunden bis die HyperV Verwaltung wieder zugänglich war.
    betroffen war hier n server 2016 auf DL180 G6 , testserver mit jeder menge hp bastelstuff… :)

  • Uwe

    super, hat gut funktioniert. Auch auf einem Dell Rechner mit Windows 10 1703

  • Martin L.

    Vielen dank, der Befehl hat auch bei mir das Verbindungsproblem gelöst, nun kann ich wieder meinen Hyper-V Server managen

  • Ronny Smiatek

    Nachdem ich meinen HP Microserver (inplace) auf 2016 geupdate habe, zog ich per HP SPP 2016 (ServicePackProLiant) sämtliche möglichen Treiber und Firmwareversionen nach oben.

    Beim ersten Auftreten half scheinbar noch ein mehrfaches De- und Neuinstallieren der HV-Rolle, plus Updates, denn es ging plötzlich wieder. Anfänglich ließen sich die VMs nicht starten, die VM-Netzwerkadapter hatten sich mit „Konfigurationsfehler“ verabschiedet. Neuer VM-Switch, VMs neu darauf verbunden, iO.

    Nun hatte ich noch die HP SPP 2017.04 rumliegen, nachdem ich damit weitere Updates der Treiber & Firmware aktualisiert hatte, trat der Zugriffsfehler aufgrund WMI auf.
    Rechteanpassungen, Hyper-V-Rolle de- und neuinstallieren, alles ohne Erfolg.

    Mit deinem Eintrag aber direkt behoben, vielen Dank!

    Ronny

  • Oliver G.

    Habe heute unter 2016 den iLO2-Treiber vom 2008R2 auf einem ML370G6 (von Hand entpackt) eingespielt. Die anschliessende Installation der WBEM-Quelle für HPE hat dann den HyperV-Manager gecrasht. 3 Stunden Recherche brachten mich hierher. Der mofcomp-Aufruf hat auf Anhieb funktioniert. Lediglich die Bootreihenfolge steht auch bei bei mir auf „bootmgfw.efi“. Alle ursprünglichen Geräte fehlen jetzt. Die VM startet aber ohne Probleme.

    Danke für die Hilfe!

Einen Kommentar hinterlassen:

Antispam Bee hat Bent's Blog vor 503.398 Spam-Kommentaren bewahrt.